一,K线沿着5日均线往上爬的通达信公式

w1:ma(c,5);


w2:abc(c-w1)/w10.01;

xg:count(w1ref(w1,1),5)=5 and w2;


二 ,第一天股票涨停,第二天成交量是第一天成交量的1倍,并超过10%.那第三天就是买点

w1:=ref(c,2)/ref(c,3)1.1;

w2:=ref(v,1)/ref(v,2)2;

xg:w1 and w2


三 ,一条均线18MA 股价上涨后“缩量”回调到18MA

XG:COUNT(VREF(V,1) AND CO,N)=N AND CMA(C,18);

N “缩量”回调的天数

四 第一天收阴,第二天,第三天,第四天,收出红三兵

XG:REF(C,3)REF(C,4) AND COUNT(CO,3)=3;

、振幅大于5%,收盘价大于3.5小于15元,三日均线大于昨日的三日均线,去掉ST股。

a1:=h/l1.05;

a2:=c3.5 and c15;

a3:=ma(c,3)ref(ma(c,3),1);

xg:a1 and a2 and a3;


六 ,60个交易日内,涨幅大于9.9%(涨停)的天数

count(c/ref(c,1)1.099,60);

、当天开盘价与收盘价相等的选股公式

xg:c=o;



八 ,kdj的J从上向下穿越O轴发出信号

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1),COLORWHITE;

D:=SMA(K,3,1),COLORYELLOW;

J:=3*K-2*D,COLORFF00FF;

xg:cross(0,j);

、股价回抽20日均线选股公式

xg:ref(c,1)ma(c,20) and cross(ma(c,20),c);

十、5日均线向上 流通盘小于5000万 换手率大于3的选股公式

lt:CAPITAL/1005000;

换手:=VOL*100/CAPITAL3;

w1:ma(c,5)ref(ma(c,5),1);

xg:lt and 换手 and w1;


1,两天内,累计下跌等于或超过20%选股.

xg:(ref(c,2)-c)/c0.2;

2、9,"阴转阳"的公式(也就是昨天收阴线,今天收阳线)

xg:ref(c,1)ref(o,1) and co;

3、count(x,n) 意思是n天内出现过信号的,假设n=10,那么就是10天内出现信号(包括今天),如果不加这个的话,就是限定在今天出信号才选出来,以前的不管。

4、15,选出10天内出现了涨停的个股

count(c/ref(c,1)1.1,10)0;

又:

今涨停:=C/REF(C,1)1.09;

选股:count(今涨停,n);

5、涨停开盘跌停收盘选股

xg:h/ref(c,1)1.1 and ref(c,1)/l1.1;

6、连续4天的收盘价格波动幅度在3%之内连续走平或向上

count(abs(c-ref(c,1)/ref(c,1))0.03 and cref(c,1),3)=3;

7、下影线长于上影线

(c-l)(h-c);

8、编买入公式:

1. 将BIAS指标的参数设置为24日,将KD指标的参数设置为9;3;3。

2. BIAS指标要小于-6,这只是确认该股超跌的初选条件。

3. KD指标产生黄金交叉,K线上穿D线。

4. KD交叉同时,KD指标中的D值要小于16。

BIAS3 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,colorff00ff;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1),COLORWHITE;

D:=SMA(K,3,1),COLORYELLOW;

xg:BIAS3-6 and cross(k,d) and d16;

9、量比大于1 同时换手大于2的公式

xg:v/ref(v,1)1 and AMOUNT/CAPITAL*1002;

10、选出当日收盘价突破10日均线5%的个股

cross(c,ma(c,10)*1.05);

通达信选股公式:

二次金叉选股:

DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=(DIFF-DEA)*2;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA=0));

二次金叉

:CROSS(DIFF,DEA) AND DEA0 AND COUNT(JCCOUNT=2,21)=1;

黄金柱选股

VAR1:=VREF(V,1)*2;

REF(VAR1,3) AND COUNT(CREF(C,3),3)=3;

凹口起柱:

T7:=REF(VOL,6)/REF(VOL,7)=2;

T6:=REF(VOL,5)/REF(VOL,6)=2;

T5:=REF(VOL,5)/REF(VOL,4)=1.5;

T4:=REF(VOL,4)/REF(VOL,3)=1.5;

T3:=REF(VOL,2)/REF(VOL,3)=1.5;

T1:=V/REF(VOL,1)2;

T0:=CO AND CREF(C,1);

选股

:T7 AND T1 AND T0 OR T6 AND T1 AND T0 OR T5 AND T1 AND T0 OR T4 AND T1 AND T0

微信公众号.jpg